QTAKE Server USER GUIDE 2.1

ABOUT QTAKE

QTAKE is the most advanced software designed and developed for video assist and DIT professionals. It is used to log, capture, playback, edit and process video output and RAW recording of the digital cinema cameras.

ABOUT QTAKE SERVER

QTAKE Server is the center-point of the QTAKE ecosystem. It is a metadata collaboration system specialized for on-set use with iPad or iPhone. Thanks to tight integration with high-end QTAKE Video Assist system, it provides instant review of each take on QTAKE Monitor clients. This immediate access to media is the key to accurate and efficient annotation by any department that can supply valuable data for production workflow. In addition to local on-set use, QTAKE Server can run in the cloud to provide secure worldwide access, or push the data into your existing digital asset infrastructure.

HOW IT WORKS

Once QTAKE synchronizes a project with QTAKE Server it will upload h264 media files and metadata to QTAKE Server which in turn makes those files available to clients using the QTAKE Monitor application. This enables the clients to request and review any recorded clip directly from QTAKE Server independently of QTAKE. Like QTAKE, QTAKE Server also supports extensive clip metadata. Any information entered on iPad will be immediatelly synchronized between all clients and QTAKE to keep all users and systems up to date.

QTAKE Server client access is based around Users and Roles. When Users first connect to QTAKE Server they have no Role. Assigning a Role to a User defines their level of access. Without an assigned Role a User is only able playback clips and view basic metadata. With a Role a user can be given permission to see and edit all metadata, create new metadata groups and add fields to existing metadata groups.


SYSTEM REQUIREMENTS

QTAKE Server 2.1 requires OS X 10.14.6 (Mojave) or higher. A network connection.

QTAKE Requirements

QTAKE version 1.5 or later.

QTAKE Monitor 4.0 or later.

Client Requirements

Supported devices for clients connecting to QTAKE Server include any iPhone, iPad or iPod touch running iOS 13.

You can always find up to date QTAKE hardware recommendations at: http://qtakehd.com/hardware/

BEFORE YOU START

For performance reasons make sure to UNCHECK the following feature in OS X System Preferences:

  • Energy Saver - Put hard disk(s) to sleep when possible.
  • Also it’s recommended to set the Computer sleep to NEVER.
  • Turn off SPOTLIGHT indexing service for your MEDIA location in System Preferences, by putting the location into the PRIVACY section. See the MEDIA LOCATION section for more information about QTAKE Server media storage.

INSTALLATION

To install QTAKE Server simply download the QTAKE Server installer and run it. You will be guided through the installation process.

The first time you run QTAKE Server you will be greeted with a EULA (End User Licensing Agreement). You will need to enter Name, Company, Email and Address of the Licensee in order to accept the EULA. QTAKE Server will also create a folder in /Applications called QTAKE Server. This folder contains the following subfolders:

  • /Applications/QTAKE Server
    • /Docs (contains QTAKE Server User Guide)
    • /Log (contains application log)
    • /License (contains license file)

QTAKE Server License

Licenses for QTAKE Server can be rented through the QTAKE Shop. In order to rent QTAKE Server from the QTAKE Shop you will need to create a QTAKE Shop account and register one or more MACHINE IDs (based on dongle or computer ID) to your QTAKE Shop account. Once a MACHINE ID is registered to your account you can rent QTAKE Server or modules for QTAKE through the shop adding additional features and functionality to your QTAKE package with a few simple clicks.

You can also create a QTAKE Shop account and register your machine directly from QTAKE Server. See the LICENSE section for more information.

If you are downloading a license file directly from the shop you should uncompress it and place it in /Applications/QTAKE Server/License.

To create a QTAKE Shop account, register machines and rent QTAKE Server or QTAKE modules visit the QTAKE Shop at: http://shop.qtakehd.com

For instructions on how to use the shop please see: https://shop.qtakehd.com/instructions

QTAKE Server functionality is seprated into several modules:

SYNC Module

SYNC is the base module that provides most of the QTAKE Server functionality: synchronizing projects, managing users and roles, creating import and export folders. It can serve local network clients and optionally connect to QTAKE Cloud Sync. While multiple projects can be uploaded to QTAKE Server, only a single project can be active with SYNC module.

IO Module

IO module is used to integrate with 3rd party services. New clip metadata and proxy media will be immediately uploaded to Moxion or Shotgun to keep their users automatically up to date.

DIT Module

DIT module provides standalone operation of QTAKE Server, independent of QTAKE Video Assist. It is recommended for DITs who want to provide on-set access to dailies using iPhone, iPad and Mac.

AVID Module

AVID module adds AVID export functionality to QTAKE Server. In addition to native DNxHD and DNxHR transcoding, it provides export of the complete clip metadata using ALE files.

CENTRAL Module

CENTRAL module is used to run your own central server in case QTAKE Cloud Sync is not an option. It provides synchronization of multiple units as well as client access over the internet.

MULTI Module

MULTI module allows you to activate up to 5 projects. Active projects can run simultaneously, providing full functionality using a single instance of QTAKE Server.

PRO Module

PRO module allows you to synchronize other clip media types, such as ProRes, DNxHD, RAW, etc.

USER INTERFACE

QTAKE SERVER UI

QTAKE Server user interface is designed as a single window with multiple tabs to provide simple and fast access to all features.

  1. User button - Allows you to log in with your user credentials.
  2. Server tabs - Synchronize with remote servers and view the status of your server and license.
  3. Notifications area - Displays notifications such as project synchronization requests and user approval requests.
  4. Project selector - Lists local projects and lets you select a project to work with.
  5. Project tabs - Approve users, manage permissions and media in the selected project.
  6. Main application area - Shows controls for the selected tab.

NOTE:
The Server status tabs are always accessible, even when you do not have a project selected. The Project tabs (Users, Roles, Clips, Files and IO) are only available when a project has been selected.

PREFERENCES

When running QTAKE in the foreground as an active application, you can access its menu items. Preferences pane is located in the main menu, under the application name.

Enable Bonjour Service

This allows computers running QTAKE or QTAKE Server and iOS devices running QTAKE Monitor to find the server on the local network. If the bonjour service is disabled clients and other servers will need to manually enter the hostname or IP address of the server in order to connect.

Host Name

This is the address that QTAKE clients will use to connect to the QTAKE Server. Project links and Server links will by default include the Bonjour name of your server. The Bonjour name will however only work on a local network (provided the Bonjour service is not disabled). If you are setting up a remote or cloud based QTAKE Server you can use this field to provide either a fully qualified domain name or a public IP address. Clicking Reset will revert the field back to the Bonjour name of your computer.

SSL Certificate

The Preferences window also allows you to add an SSL Certificate to QTAKE Server. The SSL Certificate is used to ensure that the holder is the owner of the domain name. Since the certificate is tied to a domain name it is only useful for remote or cloud based QTAKE Servers. Having an SSL Certificate avoids having to share Project or Server Links before synchronizing project between QTAKE Servers. You can obtain an SSL Certificate from a Certification Authority (CA) and we recommend to install an SSL Certificate when deploying a cloud-based QTAKE Server.

The CA will provide you with the certificate and a private key. Press the Change button next to SSL Certificate. Then paste the Certificate and Private key into the corresponding boxes. If the CA provided you with an encrypted private key then QTAKE Server will automatically check the Encrypted checkbox and you will be required to enter the Password you specified in the process of obtaining your certificate.

To go back to using the default self-signed certificate press Remove.

An SSL Certificate is recommended when setting up a QTAKE Server with a domain name. Having a certificate avoids having to send a project or server link in order to synchronize.

NOTE:
For further information about SSL Certificates, passwords, firewall settings and security in general, see the SECURITY section of this User Guide.

MEDIA FOLDERS

By default QTAKE Server stores its media files in ~/Library/Application Support/com.in2core.QtakeServer/Media. You can add additional media location by clicking a + button below. A dialog will appear allowing you to type in or browse for the new media location. In case you wish to remove existing media location, its media will be migrated to the new media location.

NOTE:
Do not attempt to manually add or remove clips from the media directory. QTAKE Server only accepts files uploaded from QTAKE or QTAKE Monitor or imported via a watch folder.

RECOMMENDATION:
When running QTAKE Server on the same computer as QTAKE, it is strongly recommended to use the same media drive. To do so, create a new folder (e.g. QTAKE Server Media) at the root level of your media drive and add it here. When sharing a media drive with QTAKE, QTAKE Server will use hard links to avoid having to copy your media. Note that while hard links are indistinguishable from actual copies in the Finder, you will know the system is working correctly when incoming media is tagged with a Local Link badge in the Files tab.


USER ACCOUNT

Click the User button to login or create a QTAKE Server user account. A QTAKE Server account is needed in order to synchronize projects with other servers. If you already have a QTAKE user account you can login with the same credentials. If you already have a QTAKE Shop account you can also choose to use the same credentials for QTAKE Shop. This saves you having to login to the QTAKE Shop separately in the License tab.


SERVER

SYNCHRONIZING

The Server tab lists local and remote projects and lets you synchronize projects between multiple QTAKE Server applications. The main program area is divided into two columns. The left column lists local projects. These projects have either been created by QTAKE Server or uploaded from QTAKE or synchronized from another QTAKE Server. The Creator column lists the email of the user that created the project.

Security is paramount when making project assets available over a network. QTAKE and QTAKE Server employs a multi-layered security approach. An internet facing QTAKE Server with a domain can verify its authenticity with an SSL certificate. However, a local server cannot, so in order to ensure its identity QTAKE Server deploys pre-shared certificate fingerprints. Before QTAKE clients (QTAKE, QTAKE Server and QTAKE Monitor) can connect to a QTAKE Server project the server needs to provide such a fingerprint via the Share Project Link button. Project links can be shared to QTAKE Monitor via QR code, AirDrop, Messages, Mail or other applications that support hyperlinks.

Upload or Download a Project

The Remote Servers and Projects list is by default populated with the QTAKE Servers that have been located via Bonjour on the local network. If a project link has not been shared the server will be marked with a orange dot. Hovering the mouse over a status dot will show the status of the connection. When the remote servers status dot is green you can request to download projects that you have added links for. You can alternatively select a local project to upload. The remote server administrator will receive a notification and can approve the upload request.

To add a server that is not on the local network or has disabled the Bonjour service (see the ENABLE BONJOUR SERVICE section above) click the plus sign (+) at the bottom of the Remote Servers and Projects list. You will then have to manually enter the IP address or the host name of the remote server to add.

Once a project has either been downloaded from, or uploaded to a remote QTAKE Server the projects will stay synchronized, provided there is a network connection between the two QTAKE Servers.

NOTE:
Typically, connections from one server to another are established in one direction. For example, a local network server will connect to the IP or host name of a central server. However, when two servers can see each other on a local network via Bonjour, you will either have to make sure the connection is established successfully in both directions or disable Bonjour.

Remove Projects from QTAKE Server

The Server tab also lets you remove local projects from QTAKE Server. Simply select the project in the Local Projects list and click Remove Project. This will also remove all media associated with that project.


Connections

The Connections tab lists projects and clients (devices) connected to the local projects of your QTAKE Server. The columns of the list shows the Name, User, Status and the last time the Status Changed for each device.

Log

The Log tab shows the application log for QTAKE Server. When troubleshooting issues you might be asked to provide the application log for QTAKE Server. Clicking Send Log will take a snapshot of the current application log and open it in your default email client. Change the Subject field and add any additional information regarding the issue to the body of the email message. You can also copy and paste the contents of the message into an external email client.

License

The License tab gives you an overview of your Computer ID, Dongle IDs from connected dongles and any module licenses you have downloaded from QTAKE Shop. In the top right of the main application area you can see the QTAKE Shop account that is currently logged in. If you would like to log in to a different account or create a new account click the Log In button.

Clicking the Go to QTAKE Shop button will open Safari and take you directly to the QTAKE Shop. The Update button will download any available licenses from the QTAKE Shop. If you are not logged in to a QTAKE Shop account when pressing the Go to QTAKE Shop or Update buttons you will be prompted for your details and have the ability to create a new account. The Show EULA lets you review the QTAKE Server End User License Agreement.


PROJECTS

PROJECT

The Project selector is drop-down menu containing all the projects that have been uploaded or synchronized with QTAKE Server. To make changes to a project or users connected to that project, select it from the list. The Users, Roles, Clips, Files and IO tabs will become active when a project has been selected. Note that projects you download will appear in this menu only after the initial sync is completed.

USERS

When a client tries to connect to a QTAKE Server their email address will appear in the Users list.

They can then be approved for basic playback access by clicking the check box in the Approve column. An approved user with No Role will not have access to any metadata other than the CAM, ROLL, SCENE, SHOT, TAKE and RATING information.

The Full Name and Profession fields can be edited by double clicking on the area next to the Approve checkbox.

Clicking the Ban checkbox will mark the selected user as banned. The user name (email) will appear with a line through the name to identify it as banned. A banned user is automatically unapproved and denied access to QTAKE Server.

NOTE:
There is no need to “create” users in QTAKE Server before they connect. Instead, users sign up with QTAKE Cloud in the QTAKE Monitor application and appear in the Users list automatically after receiving a project link or scanning the project QR code. This simplifies user management since users only have to be approved with a single click in QTAKE Server.

DEVICES

Each user account can be associated with multiple devices. Using the DEVICES table, you can approve each user device independently.

NAME column shows the name of the device client is using to connect to server. APPLICATION column displays the name of the connecting application. APPROVE column shows checkbox used to approve client device. STATUS column is used to check the connection status. However your mouse over the dot to see more details.

Approve

In addition to table column, there is a separate approval checkbox located in the device permissions view. New devices using approved user accounts will automatically be approved.

Allow Screenshot

Allows selected device to take screenshots. Screenshots are placed in the iPad’s photo library.

Disable Watermark

Will disable the overlaid watermark for selected device.

Allow Downloads

This checkbox enables caching of the media in QTAKE Monitor. When disabled users will not be able to playback clips without connection to server.

Require Connection

This dropdown is used to select what kind of connection is required to access clips. Following options are available:

  • NO - there is no requirements, device can access clips in offline mode
  • ANY SERVER - device can access clips when connected to a cloud or local server
  • LOCAL SERVER - local server connection is required to access clips

Touch ID or Passcode

This dropdown is used to control project access for selected device. Following options are available:

  • DO NOT REQUIRE - project can be accessed on a device that has no passcode
  • REQUIRE - passcode is required for project access
  • REQUIRE AND VERIFY -

WATERMARK

A custom Copyright Watermark can be created for each project. Users will see this watermark together with their Email displayed as an overlay when playing back clips in QTAKE Monitor. The top slider controls the Opacity of both watermarks. The Alignment, Vertical Position and Maximum Size of the Copyright watermark and the Client Name watermark are individually adjustable. The watermark can be disabled for individual roles. The watermark settings for a project are synchronized with QTAKE.

BINS

Many parts of QTAKE Server uses a concept called BIN to display or process a subset of the clips in the project. The Role Clip Filter, PDF Report and Export Folders all use bins to define what clips to display or include. Regular bins are similar to folders, users have to manually add clips to them.

SMART BINS

A SMART BIN is a special kind of bin, which is automatically populated with clips using custom rules. QTAKE Server defines a few default bins, but using QTAKE or QTAKE Monitor application allows you to create custom Smart Bins based on any of the metadata fields.

SHARING BINS

To create a shared bin on your iPad or iPhone, swipe left over its name in the list of bins and tap Share. These bins can then be used in QTAKE Server to, for instance, export a custom PDF Report that only includes clips from that bin. Bins can also be combined to further narrow down the selection of clips. For example, creating a shared bin that only includes clips from a specific scene and combining that with the Starred bin will only show you clips from that scene with a one or more star rating.


ROLES

Roles are in essence a group of users with a similar function on set. In order for users to read and write additional metadata of the clips a Role needs to be created and assigned to them. To create a Role click the plus sign at the bottom of the Roles section of the interface. When the Role is selected you are able to give it a name and change its permissions.

COPY TO PROJECT
Instead of recreating Roles and metadata fields in each project you can copy them from one project to another with the Copy to Project button.

Allow Admin Access

This option is giving the Role access to the ADMIN interface in QTAKE Monitor. This allows the User to Approve, assign Roles, Ban and change permissions of other Roles from QTAKE Monitor without having to go through the QTAKE Server interface.

Allow Recording and Import

This checbox will grant Role permission to create new clips using record or import functions in QTAKE Monitor.

Allow Adding Metadata Groups

This allows the Role to add custom groups of metadata. See the Metadata section for more details.

Allow Removing Metadata Groups

This allows the Role to remove custom groups of metadata. In addition to this the Role also needs to have Remove Fields permission in that group in order to remove the group itself.

Clip Filter

In addition to permissions above, Role can also limit access to clips. This is done through shared bins. Users assigned this Role will be able to access only the clips that are contained in selected bins.


METADATA AND PERMISSIONS

Information about a clip, such as the slate information or the shutter angle of the camera, is called metadata and is organized into Metadata Groups in QTAKE and QTAKE Server. Every project has a set of default metadata Groups called Predefined Groups. A user with the correct permissions can add Fields to those groups but it is not possible to remove predefined Groups or Fields. In the Users tab you can control the permissions for each role in regards to metadata groups. The following permissions can be assigned:

Permission Effect
Read Role can view the group and all fields but is not allowed to change any values
Write Role can view fields and change values
Add Fields Role can add custom fields in addition to being able to change values of existing fields
Remove Fields Role can remove custom fields in addition to being able to change values of existing fields*
  • Predefined fields cannot be removed.

In addition to the above a role can be given permission to add or remove complete metadata groups. In order to remove a group the role also needs Remove Fields permission for that group.

The Color column in the Metadata Group table allows you to set the color tint of the Metadata Group in QTAKE Monitor. Changing the color is purely cosmetic, distinct colors eases navigation between the Metadata Groups.

CAUTION
Giving a Role permission to Remove Metadata Groups or Remove Fields can be dangerous. Removing fields or groups will remove all data associated with those entities for all users. Assign permissions with care.

CLIPS

The Clips tab shows the currently selected projects clips along with the Clip Processing Status. Clips with the Failed status message next to them have not been imported either because a h264 proxy file was not recorded by QTAKE or that the imported file format was incompatible. For files originating from a Watch Folder see the IO section below.

Clip Filters

The Bins list lets you filter what clips that appear in the Clips list by checking or unchecking various bins. The Bins list will, in addition to the default Smart Bins, display any user created bins that have been marked as Shared. See BINS for more information.

Media

The Media list shows what media files are uploaded to QTAKE Server for the selected clip in the Clips list. The Settings button opens a window that lets you choose what media QTAKE Server should request and store for the clips in the project. Each column represents one media type and you can further refine what clips are uploaded using bins. See BINS.

PDF EXPORT

QTAKE Server can generate PDF Reports with thumbnails and metadata for each clip. The selection of clips included in the report is defined by what shared bins are selected in the Clips tab. PDF Reports are generated based on a template that defines the layout and content of the report. QTAKE Server includes two predefined templates, a Project Report template and a Camera Report template. You can create new templates by duplicating and editing one of the existing templates (See Creating a Template for more details) in the template editor. The flexibility of the template editor allows for custom reports for any departments that require them.

PDF Report Templates

To create a new PDF report template click on the PDF Report button in the Clips tab (or go to File menu, PDF Report) and select the report you would like to base your new report on. Click the Duplicate button and name your new PDF report template. The left side of the template editor lets you choose what metadata fields are included and the sorting order of the clips in the report.

Adding and Removing Metadata Fields

Use the segmented button to choose wether the fields should be added to the page header or the individual clip entries in the report. To add a field select it from the Available Fields list and use the arrow button (>) to add it. When the report is in Flow Layout both the Page Header and the clip entires have a heading and a data section. These are separated by a horizontal line in the Included Fields list. Drag the field to move it between the data section and the heading. Each field in the Included list also has a drop-down menu to define its relation to the next field. The options are No Space, Slash, Space and New Line.

Fields added to the Page Header will show up in the gray section of the preview. The Page Header will be repeated at the top of each page in the report. The header would normally be populated with fields from the Project Data group but you can optionally add fields from other groups. If fields with multiple values are added the header will show all values separated by commas.

The Sort Order tab lets you control the sorting of clips and the page breaks of the report. Clips in the report are sorted, in order from top to bottom, by the fields in the Included Fields list. There is a horizontal bar dividing the Included Fields list into two sections just like in the Clip and Page Header. Fields added above this line will cause the report to be divided into sections separated by page breaks based on their values.

REPORT LAYOUT

The right side of the template editor contains a preview of the report, and controls for the page layout of the report. A segmented button near the top lets you choose between a Flow Layout and a Table Layout for the report. Select the Camera Report in the Template drop-down menu for an example of a report in table layout.

You can add the name of the template and the date when the report was generated to the report header by checking the Show template title in page header and Show date in page header checkboxes.

Checking the Full header on first page only checkbox will remove fields below the horizontal line in the Page Header tab on all pages of the report except for the first.

The bottom row of controls allows you to change the layout of the clip entries. Unchecking Begin each group on a new line allows for more compact layout by putting the metadata groups closer together. Use fixed field positions and sizes will make sure the fields stay in the same place in each clip entry by adjusting the size of the field in the report to accommodate the clip with the largest amount of characters in that field. Use full-width clip headers will adjust the thumbnail to allow more information in the header. Skip empty fields will remove fields without data from the report. You can also adjust the thumbnail position and row decoration for the clips.

FILES

The Files tab shows the upload status of all metadata attachments in the selected project. Metadata attachments are created when photos or videos are uploaded to an Attachments type field by a QTAKE or QTAKE Monitor client.

IO

The IO tab contains controls that let you setup watch folders to import media and export folders to export media from the project. The Upload Integrations section lets you configure QTAKE Server to sync to third party collaboration services such as Moxion or Shotgun.

Watch Folders

A watch folder is a designated folder that provides a means of importing clips directly into a QTAKE Server project. Once a watch folder has been set QTAKE Server will periodically check that folder for any new media.

To setup a watch folder first make sure that the project you want to use is selected in the project selector drop-down menu then click on the Watch Folders button in the tab selector. Click the small plus sign in the bottom left corner and browse for the folder you want to designate as a watch folder. QTAKE Server will immediately catalog the contents of the folder. You can monitor the progress of the import process in the right hand column.

By default QTAKE Server will only import media that has a matching Camera Media Filename(CMF) and clip in the project database. This allows you to replace existing QTAKE Server media with graded media from an external dailies software solution. By selecting Create new clips for added media files you can override the default behavior and have QTAKE Server import any compatible media it finds, creating new clip entries for those that do not match an existing clip and CMF. You can also copy whole folder structures into the Watch Folder. QTAKE Server will interpret subfolders as /SCENE/SHOT/TAKE/ metadata when importing clips.

Selecting Delete processed media files will remove files from the watch folder after they have been imported.

EXAMPLE
/WatchFolder/10/A/1/Clip.mov will add the following metadata: Scene:10 Shot:A Take:1 /WatchFolder/11/Clip.mov will add the following metadata to the clip: Scene:11

Export Folders

Use the Plus (+) button to add an Export Folder. The Export Bins list lets you filter what clips are included in the export by checking or unchecking the checkbox next to the bins. Each export folder can have its own set of bins. See BINS.

The Media Type dropdown lets you select what type of media to export to the folder. The Filenames dropdown lets you choose whether the media should use QTAKE Filenames or Camera Media Filenames and you can even create custom filenames by creating a new template with the Filename Templates button. You can also choose whether the files should be organized into subfolders based on Camera, Scene and Shot metadata or not. Clicking the checkbox will start the export of QTAKE Server media to the folder. As long as the checkbox is ticked, new media will be copied to the export folder.

NOTE
In order for the media to be exported to an Export Folder it first needs to be uploaded to QTAKE Server. You can select what media QTAKE Server should request in the Clips tab.

Upload Integrations

The Upload Integrations list lets you upload media from your project to external third party media collaboration sites. QTAKE Server currently supports Moxion and Shotgun. Click the plus (+) button to add an entry to the list. Upload Integrations are disabled by default allowing you to adjust settings before the upload begins. The Upload Bins list allows you to filter which clips to upload by checking or unchecking certain bins. Click the Enable checkbox when done to initiate the upload. Qtake will automatically upload new clips that match the selected bins.

SECURITY

LOCAL QTAKE SERVER

To ensure that the communication between the server and its clients cannot be intercepted or eavesdropped on, QTAKE Server deploys pre-shared certificate fingerprints. Before QTAKE clients (QTAKE, QTAKE Server and QTAKE Monitor) can connect to a QTAKE Server, the server needs to provide such a fingerprint via the Share Project Link or Share Server Link buttons. Project and Server links can be shared to QTAKE Monitor via QR code, AirDrop, Messages, Mail or other applications that support hyperlinks.

Wi-Fi Security

We recommend using WPA2 encryption and a password that is not easily guessable. Due to the way WPA2 works, it is also a good idea to choose a non-trivial name (SSID) for the network.

Device Security

Devices (iPhones, and iPads) are automatically encrypted. In order to take advantage of the encryption we recommend locking your device with a passcode.

CLOUD-BASED QTAKE SERVER

SSL Certificates

Instead of sharing Project and Server links, an internet facing QTAKE Server with a domain name can use an SSL Certificate to allow synchronization between it and other QTAKE clients.

The SSL certificate acts like an identity card for your server. It is issued by a Certification Authority (CA) and it proves that the holder of the certificate is the rightful owner of the signed domain name. Having an SSL Certificate installed in QTAKE Server guarantees that communication between QTAKE clients and QTAKE Server is encrypted in such a way that it cannot be intercepted or eavesdropped on by unauthorized third parties.

The CA will verify that you are the owner of the domain name, usually by sending a verification email to an email address associated with the domain name. You will then need to enter the Certificate and the Private Key into the Preferences - SSL Certificate window. See the SSL CERTIFICATE section for more details.

Firewall Settings

In order for QTAKE Server to function the computer or routers firewall need to accept incoming traffic on the following ports:

TCP 44443 TCP 8500 - 8600

NOTE
SSL Certificates can be obtained from a CA. There are many CAs, some of them offer free certificates. An example of a CA that provides free certificates is: https://www.startssl.com

TROUBLESHOOTING

TROUBLESHOOTING QTAKE SERVER

No License

Make sure the license file is unzipped and placed in /Applications/QTAKE Server/License. If you do not have a license file for QTAKE Server please contact IN2CORE.

Remote Server is Not Listed in the Sync tab

If a remote server is not listed in the Remote Servers and Projects column it means that it will have to be added manually. Click the Add Server button and enter the host name or IP address of the remote computer.

QUICK SETUP

STEP BY STEP GUIDE

This guide assumes that you have a functioning installation of QTAKE 1.5 or later and a licensed QTAKE Server 2.1 or later running on the same computer. If that is not the case please refer to the installation instructions in either the QTAKE User Guide or the QTAKE Server User Guide.

In order to test client functionality you will also need an iPad or iPhone running QTAKE Monitor 4.0 and a working network connection between the QTAKE Monitor device and the computer running QTAKE and QTAKE Server.

1) Launch QTAKE Server and navigate to the Server tab.

2) Launch QTAKE and create a NEW project taking care to enable H.264 recording for all inputs.

3) In the project list, click UPLOAD and select the computer running QTAKE Server.

4) A window will inform you that the project upload needs to be approved in QTAKE Server. Click HIDE button to minimize QTAKE.

5) Go back to QTAKE Server. You should now see the notification as well as your project in the list with a white dot, waiting to be approved.

6) After approval, select the project in the Project Selector. Then go to the Users tab. You should see the QTAKE user in the Users list with the Approved checkbox checked. Click the Connect Devices button to add QTAKE Monitor client.

7) Launch the QTAKE Monitor app and log into QTAKE Cloud. Then in the Project list, tap Scan Project Link and scan the QR code presented by QTAKE Server.

8) Go back to QTAKE Server. Set the Role of the client to Script Supervisor. This gives the QTAKE Monitor client access to playback clips and edit clip metadata.

9) Done. Clips recorded in QTAKE are now uploaded to QTAKE Server and any user with permissions can browse and playback those clips in QTAKE Monitor.